summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 12:18:06 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-16 12:18:06 +0200
commit62b0c5b934b8a555102e5dfa4c93ac3a898750bc (patch)
tree2b35e4891212518b77fd5c7ccdc931e91d51f4ae /gnu
parent72b0875da8b9b88f2cbe5f368138d1d9d0df85ca (diff)
downloadguix-62b0c5b934b8a555102e5dfa4c93ac3a898750bc.tar.gz
gnu: Add texlive-japanese-otf.
* gnu/packages/tex.scm (texlive-japanese-otf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 049c6ca657..533fe4943e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -34270,6 +34270,29 @@ using LuaLaTeX.  @code{\\NewDocumentCommand} allows you to specify whether the
 formula should be used within a sentence or on a new line.")
     (license license:lppl1.3c)))
 
+(define-public texlive-japanese-otf
+  (package
+    (name "texlive-japanese-otf")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/fonts/japanese-otf/"
+                   "fonts/ofm/public/japanese-otf/"
+                   "fonts/tfm/public/japanese-otf/"
+                   "fonts/vf/public/japanese-otf/"
+                   "source/fonts/japanese-otf/"
+                   "tex/platex/japanese-otf/")
+             (base32
+              "125z1fi13dnksngsc442n6fcmicv7hhrxrq8anzxax4ic3dqfvha")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/japanese-otf")
+    (synopsis "Advanced font selection for platex and its friends")
+    (description
+     "The package contains pLaTeX support files and virtual fonts for
+supporting a wide variety of fonts in LaTeX using the pTeX engine.")
+    (license license:bsd-3)))
+
 (define-public texlive-libertine
   (package
     (name "texlive-libertine")