summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2020-03-17 16:04:51 +0100
committerJakub Kądziołka <kuba@kadziolka.net>2020-03-29 00:02:46 +0100
commit62b9ad19e3a6638f8e077753454fdf08ba586146 (patch)
tree11a0483420e845bb992571b6fb414f238939693a /gnu
parent735a8d997a92518d7d19926e1c8a1e385a98fdce (diff)
downloadguix-62b9ad19e3a6638f8e077753454fdf08ba586146.tar.gz
gnu: Add wol.
* gnu/packages/networking.scm (wol): New public variable.

Signed-off-by: Jakub Kądziołka <kuba@kadziolka.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 6a7b0739dd..ec2f0b64bd 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2908,6 +2908,24 @@ Such interfaces are useful for VPN software, virtualization, emulation,
 simulation, and a number of other applications.")
     (license license:gpl2)))
 
+(define-public wol
+  (package
+    (name "wol")
+    (version "0.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/wake-on-lan/wol/"
+                           version "/wol-" version ".tar.gz"))
+       (sha256
+        (base32 "08i6l5lr14mh4n3qbmx6kyx7vjqvzdnh3j9yfvgjppqik2dnq270"))))
+    (build-system gnu-build-system)
+    (home-page "https://sourceforge.net/projects/wake-on-lan/")
+    (synopsis "Implements Wake On LAN functionality in a small program")
+    (description "Tool to send a magic packet to wake another host on the
+network.  This must be enabled on the target host, usually in the BIOS.")
+    (license license:gpl2)))
+
 (define-public vde2
   (package
     (name "vde2")