summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-23 17:15:15 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:20 +0300
commit62cfe906d79e3676ec95fe17fd82c2618a7cd43b (patch)
tree01a0f798ea47626f543b50e73fb75b33ea2ce044 /gnu
parenteb8f7f6c0c5297e83346e9a28eb1089804433440 (diff)
downloadguix-62cfe906d79e3676ec95fe17fd82c2618a7cd43b.tar.gz
gnu: Add rust-mp4parse-0.12.
* gnu/packages/crates-graphics.scm (rust-mp4parse-0.12): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-graphics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 7fd0187e82..52fa5a00f4 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -1605,6 +1605,36 @@ graphics and video games.")
     (description "This package provides SVG helpers for the lyon crates.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-mp4parse-0.12
+  (package
+    (name "rust-mp4parse")
+    (version "0.12.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "mp4parse" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32 "1ppqv60qiyrnbb996gb1sik08c0j2i317llv3rrcwb1cjg3bdlk7"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f              ; Not all files included.
+       #:cargo-inputs
+       (("rust-bitreader" ,rust-bitreader-0.3)
+        ("rust-byteorder" ,rust-byteorder-1)
+        ("rust-env-logger" ,rust-env-logger-0.8)
+        ("rust-fallible-collections" ,rust-fallible-collections-0.4)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-num-traits" ,rust-num-traits-0.2)
+        ("rust-static-assertions" ,rust-static-assertions-1))
+       #:cargo-development-inputs
+       (("rust-criterion" ,rust-criterion-0.3)
+        ("rust-test-assembler" ,rust-test-assembler-0.1)
+        ("rust-walkdir" ,rust-walkdir-2))))
+    (home-page "https://github.com/mozilla/mp4parse-rust")
+    (synopsis "Parser for ISO base media file format (mp4)")
+    (description "Parser for ISO base media file format (mp4)")
+    (license license:mpl2.0)))
+
 (define-public rust-osmesa-sys-0.1
   (package
     (name "rust-osmesa-sys")