summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorSohom Bhattacharjee <soham.bhattacharjee15@gmail.com>2018-03-31 20:20:49 +0530
committerLudovic Courtès <ludo@gnu.org>2018-03-31 19:23:11 +0200
commit62d1105c8844831334378b4c4e26135ee3e74a66 (patch)
treeb5d917a4a447931ed8a8ffd5a33276095bbdad2c /gnu
parent2ac9f2a2b32faab6c101729b3bc8a7088ddd55e4 (diff)
downloadguix-62d1105c8844831334378b4c4e26135ee3e74a66.tar.gz
gnu: Add emacs-anzu.
* gnu/packages/emacs.scm (emacs-anzu): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ab0f9edb55..ce9b1a66ac 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -32,6 +32,7 @@
 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Mike Gerwitz <mtg@gnu.org>
 ;;; Copyright © 2017, 2018 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2018 Sohom Bhattacharjee <soham.bhattacharjee15@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -7414,3 +7415,24 @@ the same values you get in a terminal.")
      "Deft is an Emacs mode for quickly browsing, filtering, and editing
 directories of plain text notes, inspired by Notational Velocity.")
     (license license:bsd-3)))
+
+(define-public emacs-anzu
+  (package
+    (name "emacs-anzu")
+    (version "0.62")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://stable.melpa.org/packages/anzu-"
+                           version ".el"))
+       (sha256
+        (base32
+         "1h3p1x2h2830n83dzvkh8p2892n34a95x7aavhi10p7vfjk406fd"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/syohex/emacs-anzu")
+    (synopsis "Show number of matches in mode-line while searching")
+    (description
+     "Anzu provides a minor mode which displays \"current match/total
+matches\" in the mode line in various search modes.  This is an Emacs port of
+Anzu.zim.")
+    (license license:gpl3+)))