summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-09 21:23:30 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-09 21:25:08 +0300
commit62ea0a0d3a921a25593b2a8db97d744fd2c53c08 (patch)
tree100f3a0292cf42c64a519f247d0836b4bd28555d /gnu
parenta4c35c607cfd7d6b0bad90cfcc46188d489e1754 (diff)
downloadguix-62ea0a0d3a921a25593b2a8db97d744fd2c53c08.tar.gz
gnu: global: Fix ctags creation using pygments.
* gnu/packages/code.scm (global)[arguments]: Adjust configure-flags to
use a specific python interpreter.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/code.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/code.scm b/gnu/packages/code.scm
index 9cdda2b751..1c21ad475b 100644
--- a/gnu/packages/code.scm
+++ b/gnu/packages/code.scm
@@ -200,6 +200,10 @@ highlighting your own code that seemed comprehensible when you wrote it.")
                    (string-append "--with-universal-ctags="
                                   #$(this-package-input "universal-ctags")
                                   "/bin/ctags")
+                   ;; Otherwise this gets overridden in the 'configure phase.
+                   (string-append "--with-python-interpreter="
+                                  #$(this-package-input "python-wrapper")
+                                  "/bin/python")
                    (string-append "--sysconfdir="
                                   #$output "/share/gtags")
                    "--localstatedir=/var" ; This needs to be a writable location.