summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-11 20:00:08 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-01-11 20:00:08 +0200
commit637b72e2b83a6332849218ef1f193124fa8239eb (patch)
treea950c6bbc084ed86d7fad58f2261ce460a1d7227 /gnu
parent15ba54d0e91ecb6214661f5931f058ce33cd936e (diff)
downloadguix-637b72e2b83a6332849218ef1f193124fa8239eb.tar.gz
gnu: llvm-cling: Fix build.
This is a follow-up to 15ba54d0e91ecb6214661f5931f058ce33cd936e.

* gnu/packages/llvm.scm (llvm-cling)[arguments]: Use gexps for phases.

Change-Id: I12f048b1a6a350838572832ad33357046610b18d
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/llvm.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index be18171b12..0062bc56cd 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -2267,9 +2267,9 @@ LLVM."))))
                  "-DLLVM_BUILD_LLVM_DYLIB=ON"
                  "-DLLVM_LINK_LLVM_DYLIB=ON"))
          ((#:phases phases '%standard-phases)
-          `(modify-phases ,phases
-             (delete 'shared-lib-workaround)
-             (delete 'install-opt-viewer))))))))
+          #~(modify-phases #$phases
+              (delete 'shared-lib-workaround)
+              (delete 'install-opt-viewer))))))))
 
 (define clang-cling-runtime
   (let ((base clang-runtime-9))