summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-03-22 10:35:25 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-05-07 19:29:27 +0300
commit639ef9e3572bbcee4331fdf546a4761e599ddb10 (patch)
treefe6a957b4a6e6309dff6b85c1e766adc9ce0eafa /gnu
parent12a62abbb1d780191d07c60334ac5a69e6567319 (diff)
downloadguix-639ef9e3572bbcee4331fdf546a4761e599ddb10.tar.gz
gnu: Add rust-associative-cache-1.
* gnu/packages/crates-io.scm (rust-associative-cache-1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index a52e02a746..eca776f136 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4251,6 +4251,29 @@ objects are the same.")
      "This package asserts that a value matches a pattern in Rust.")
     (license (list license:expat license:asl2.0))))
 
+(define-public rust-associative-cache-1
+  (package
+    (name "rust-associative-cache")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "associative-cache" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "05lg0mwpqfqb9zh958x0358x1k5ngmmmbzjnp0imrd8vzhrn40a6"))))
+    (build-system cargo-build-system)
+    (arguments
+     ;; 2 doctests fail because rand is not declared
+     `(#:tests? #false
+       #:cargo-inputs (("rust-rand" ,rust-rand-0.7))))
+    (home-page "https://github.com/fitzgen/associative-cache")
+    (synopsis "Associative cache with fixed-size capacity")
+    (description
+     "This package provides a generic N-way associative cache with fixed-size
+capacity and random or least recently used (LRU) replacement.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-aster-0.41
   (package
     (name "rust-aster")