summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2022-10-31 21:59:55 +0300
committerMathieu Othacehe <othacehe@gnu.org>2022-11-09 17:45:41 +0100
commit63b7dbc7327ba7c86781f0ceeaccf1b832219f09 (patch)
tree89cb86677d53511d42900585ee41bee3c7dbf18e /gnu
parent18fb7c0f3078216bf4fc865d86b3be76ddc68414 (diff)
downloadguix-63b7dbc7327ba7c86781f0ceeaccf1b832219f09.tar.gz
gnu: guile-ics: Update to 0.4.0.
* gnu/packages/guile-xyz.scm (guile-ics): Update to 0.4.0.
  [propagated-inputs]: Add "guile-dsv".
  [description]: Update.
  (guile2.2-ics): Likewise.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile-xyz.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index c9f1257380..b7630ad861 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -1794,7 +1794,7 @@ provides tight coupling to Guix.")
 (define-public guile-ics
   (package
     (name "guile-ics")
-    (version "0.3.0")
+    (version "0.4.0")
     (source
      (origin
        (method git-fetch)
@@ -1804,7 +1804,7 @@ provides tight coupling to Guix.")
        (file-name (string-append name "-" version "-checkout"))
        (sha256
         (base32
-         "1526kdzcn0qvf5hpb4x5q01vb9mph9gfw24p81inqgjvy7a57lf9"))))
+         "1wjkba135iipwqrp14c3q6wpbjhglp9d12is16lj8l81xyv8gjn3"))))
     (build-system gnu-build-system)
     (arguments
      (list #:phases #~(modify-phases %standard-phases
@@ -1817,12 +1817,13 @@ provides tight coupling to Guix.")
            help2man
            pkg-config))
     (inputs (list guile-3.0 which))
-    (propagated-inputs (list guile-lib guile-smc))
+    (propagated-inputs (list guile-lib guile-smc guile-dsv))
     (home-page "https://github.com/artyom-poptsov/guile-ics")
     (synopsis "Guile parser library for the iCalendar format")
     (description
-     "Guile-ICS is an iCalendar (RFC5545) format parser library written in
-pure Scheme.  The library can be used to read and write iCalendar data.
+     "Guile-ICS is an iCalendar (RFC5545) and vCard (RFC6350) format parser
+library written in pure Scheme.  The library can be used to read and write
+iCalendar/vCadr data and convert the data from/to various formats.
 
 The library is shipped with documentation in Info format and usage examples.")
     (license license:gpl3+)))
@@ -1832,7 +1833,7 @@ The library is shipped with documentation in Info format and usage examples.")
     (inherit guile-ics)
     (name "guile2.2-ics")
     (inputs (list guile-2.2 which))
-    (propagated-inputs (list guile2.2-lib guile2.2-smc))))
+    (propagated-inputs (list guile2.2-lib guile2.2-dsv guile2.2-smc))))
 
 (define-public guile-imanifest
   (let ((commit "ccd5a2111b008d778106f5595a3a585954d95d0")