summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-07-05 09:47:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-07-05 09:53:11 +0300
commit63f8aab69cd615633122d70604c19c8abb410e79 (patch)
tree197b2e63ceadf4f8eaad380cc083561b488a49d1 /gnu
parent52efe95ac44ae7eb793825d5eb070c6a2d7ced47 (diff)
downloadguix-63f8aab69cd615633122d70604c19c8abb410e79.tar.gz
gnu: vim-full: Remove expat linker workaround.
Python has correctly linked with expat for several years now.

* gnu/packages/vim.scm (vim-full)[arguments]: Remove make-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/vim.scm7
1 files changed, 0 insertions, 7 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 459ff18e5b..d58b022123 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -224,13 +224,6 @@ with the editor vim.")))
              "--disable-selinux"
              "--enable-gui")
        ,@(substitute-keyword-arguments (package-arguments vim)
-           ;; This flag fixes the following error:
-           ;; .../libpython3.7m.a(pyexpat.o): undefined reference to symbol 'XML_FreeContentModel'
-           ;; .../libexpat.so.1: error adding symbols: DSO missing from command line
-           ((#:make-flags flags)
-            `(append
-              (list "LDFLAGS=-lexpat")
-              ,flags))
            ((#:phases phases)
             `(modify-phases ,phases
                (add-before 'check 'start-xserver