summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-06-13 09:16:46 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-06-13 09:16:46 +0300
commit63f8af77ec7be5434290f443140e5c00832940e3 (patch)
treee571ad9196c0c788e89c968960fd98b518ed146b /gnu
parent0b2d33af03a7bfca0b58dcd5c8d551eb6927cf6b (diff)
downloadguix-63f8af77ec7be5434290f443140e5c00832940e3.tar.gz
gnu: libgit2: Skip some tests on armhf-linux.
* gnu/packages/version-control.scm (libgit2)[arguments]: When building
for armhf-linux add a phase to skip some tests.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9a27b8f1e9..1dd3eaaa82 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -846,6 +846,12 @@ to GitHub contributions calendar.")
                    '()))
        #:phases
        (modify-phases %standard-phases
+         ,@(if (target-arm32?)
+             ;; Some tests are flaky on armhf.
+             '((add-before 'check 'pre-check
+                 (lambda _
+                   (setenv "GITTEST_FLAKY_STAT" "true"))))
+             '())
          ;; Run checks more verbosely, unless we are cross-compiling.
          (replace 'check
            (lambda* (#:key (tests? #t) #:allow-other-keys)