summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-27 17:57:17 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:12:45 +0200
commit64c3ae85b742027c0a95c2d8046f9f7fb8c66a90 (patch)
tree2b84f994e8430ac55a91316c7e43feca846d064c /gnu
parentf3f888ea55e7f34b7d36fd6ae921c91931f16ee4 (diff)
downloadguix-64c3ae85b742027c0a95c2d8046f9f7fb8c66a90.tar.gz
gnu: Add texlive-knuth-local.
* gnu/packages/tex.scm (texlive-knuth-local): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5d7ba3b611..8695828d6e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1463,6 +1463,28 @@ Knuth, including the plain format, plain base, and the MF logo fonts.")
 
 (define-deprecated-package texlive-fonts-knuth-lib texlive-knuth-lib)
 
+(define-public texlive-knuth-local
+  (package
+    (name "texlive-knuth-local")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "fonts/source/public/knuth-local/"
+                   "fonts/tfm/public/knuth-local/"
+                   "mft/knuth-local/" "tex/plain/knuth-local/")
+             (base32
+              "02cf32f57fr6bngiv9xiw8bh4sq53p9br034ap74s80h3bgcmn1f")))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/knuth-local")
+    (native-inputs
+     (list texlive-knuth-lib texlive-metafont))
+    (synopsis "Knuth's local information")
+    (description
+     "This package provides a collection of experimental programs and
+developments based on, or complementary to, the matter in his distribution
+directories.")
+    (license license:public-domain)))
+
 (define-public texlive-latex-fonts
   (package
     (name "texlive-latex-fonts")