summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorGabriel Wicki <gabriel@erlikon.ch>2023-09-28 14:25:44 +0200
committerMathieu Othacehe <othacehe@gnu.org>2023-10-14 15:38:49 +0200
commit64e7081851c1412aa796a28d949f961da046a69a (patch)
treef2a0e526e561c590405cf60b6fdf0f4c377a353d /gnu
parent373ec2cf8ce97d5f89191c3d9211ee3a5c2067dc (diff)
downloadguix-64e7081851c1412aa796a28d949f961da046a69a.tar.gz
gnu: Add python-icmplib.
* gnu/packages/python-xyz.scm (python-icmplib): New variable.

Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c889f16685..1b9ac0a5f8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1830,6 +1830,28 @@ It can handle tasks such as scanning, tracerouting, probing, unit tests,
 attacks or network discovery.")
     (license license:gpl2)))
 
+(define-public python-icmplib
+  (package
+    (name "python-icmplib")
+    (version "3.0.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "icmplib" version))
+       (sha256
+        (base32 "1phnlgbb5di79ijm55pyd5jj1ggss4b6nn6mw701h501vcn8z1jp"))))
+    (arguments
+     '(#:tests? #f)) ;test data not present
+    (build-system python-build-system)
+    (home-page "https://github.com/ValentinBELYN/icmplib")
+    (synopsis
+     "Python implementation of the Internet Control Message Protocol (ICMP)")
+    (description
+     "@code{icmplib} is a supporting library for both IPv4 and IPv6 networks.
+ICMP is typically used for diagnostic or control purposes - well known from
+utilities such as ping(1).")
+    (license license:lgpl3)))
+
 (define-public python-rasterio
   (package
     (name "python-rasterio")