summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-04-22 19:01:33 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-05-11 21:58:02 +0200
commit659692c0c31bd91abbfe778e798c481b24292900 (patch)
treece9c55a1d82293d86be96bddb126062eb8a56928 /gnu
parent03a34e87b8a1e808792c93f3af52e32479353838 (diff)
downloadguix-659692c0c31bd91abbfe778e798c481b24292900.tar.gz
gnu: Add python-django-contrib-comments.
* gnu/packages/django.scm (python-django-contrib-comments,
python2-django-contrib-comments): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/django.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/django.scm b/gnu/packages/django.scm
index c1deac89b9..260a689fca 100644
--- a/gnu/packages/django.scm
+++ b/gnu/packages/django.scm
@@ -412,3 +412,28 @@ for Django sites.")
 
 (define-public python2-django-contact-form
   (package-with-python2 python-django-contact-form))
+
+(define-public python-django-contrib-comments
+  (package
+    (name "python-django-contrib-comments")
+    (version "1.8.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "django-contrib-comments" version))
+              (sha256
+               (base32
+                "0bxsgw8jrkhg6r5s0z6ksfi4w8yknaqb1s9acmxd9pm3pnsnp5kx"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-django" ,python-django)))
+    (home-page "https://github.com/django/django-contrib-comments")
+    (synopsis "Comments framework")
+    (description
+      "Django used to include a comments framework; since Django 1.6 it's been
+separated to a separate project.  This is that project.  This framework can be
+used to attach comments to any model, so you can use it for comments on blog
+entries, photos, book chapters, or anything else.")
+    (license license:bsd-3)))
+
+(define-public python2-django-contrib-comments
+  (package-with-python2 python-django-contrib-comments))