summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-02-07 13:30:02 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-02-08 09:26:18 +0200
commit6598e4c56bb94c5032245e54d4f8aeee7fc94f31 (patch)
treeabd8ec07c646ae71f44250be8d7d65ad513f43a5 /gnu
parent99c1c7a30c59c3514a4ced6e0cad0e5c2860331d (diff)
downloadguix-6598e4c56bb94c5032245e54d4f8aeee7fc94f31.tar.gz
gnu: openbios-qemu-ppc: Fix building on aarch64-linux.
* gnu/packages/firmware.scm (openbios-qemu-ppc)[arguments]: When
building from aarch64-linux build for armhf-linux.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/firmware.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/firmware.scm b/gnu/packages/firmware.scm
index 029e84d5c2..fea7d37923 100644
--- a/gnu/packages/firmware.scm
+++ b/gnu/packages/firmware.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2017 David Craven <david@craven.ch>
-;;; Copyright © 2017, 2018, 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Vagrant Cascadian <vagrant@debian.org>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -414,6 +414,11 @@ provide OpenFirmware functionality on top of an already running system.")
       (inherit base)
       (arguments
        (substitute-keyword-arguments (package-arguments base)
+         ((#:system system (%current-system))
+          (if (string-prefix? "aarch64-linux" (or (%current-system)
+                                                  (%current-target-system)))
+            "armhf-linux"
+            system))
          ((#:phases phases)
           #~(modify-phases #$phases
               (add-after 'install 'rename-executable