summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2022-02-06 00:29:16 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-02-06 00:29:16 +0100
commit65df5a4eb25fd6c42575df62b13655f99cf9d806 (patch)
tree3794c0082ad8b791124a7a46452d8cd3d7f4b8f2 /gnu
parentd5f8bfcd14b29bc795a1bc7a18fcbcb5276d4df2 (diff)
downloadguix-65df5a4eb25fd6c42575df62b13655f99cf9d806.tar.gz
gnu: poppler: Use gexps in arguments.
* gnu/packages/pdf.scm (poppler)[arguments]: Transform from quasiquote to list
of gexps.
<#:phases>: Always bind, using %standard-phases as explicit default.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/pdf.scm30
1 files changed, 14 insertions, 16 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index a7eaea991c..fb4e545160 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -257,22 +257,20 @@ please install the @code{flyer-composer-gui} package.")))
             `(,glib "bin") ; glib-mkenums, etc.
             gobject-introspection))
    (arguments
-    `(#:tests? #f                      ;no test data provided with the tarball
-      #:configure-flags
-      (let* ((out (assoc-ref %outputs "out"))
-             (lib (string-append out "/lib")))
-        (list "-DENABLE_UNSTABLE_API_ABI_HEADERS=ON" ;to install header files
-              "-DENABLE_ZLIB=ON"
-              "-DENABLE_BOOST=OFF"      ;disable Boost to save size
-              (string-append "-DCMAKE_INSTALL_LIBDIR=" lib)
-              (string-append "-DCMAKE_INSTALL_RPATH=" lib)))
-      ,@(if (%current-target-system)
-            `(#:phases
-              (modify-phases %standard-phases
-                (add-after 'unpack 'set-PKG_CONFIG
-                  (lambda _
-                    (setenv "PKG_CONFIG" ,(pkg-config-for-target))))))
-            '())))
+    (list
+     #:tests? #f                      ;no test data provided with the tarball
+     #:configure-flags
+     #~(list "-DENABLE_UNSTABLE_API_ABI_HEADERS=ON" ;to install header files
+             "-DENABLE_ZLIB=ON"
+             "-DENABLE_BOOST=OFF"      ;disable Boost to save size
+             (string-append "-DCMAKE_INSTALL_LIBDIR=" #$output "/lib")
+             (string-append "-DCMAKE_INSTALL_RPATH=" #$output "/lib"))
+     #:phases
+     (if (%current-target-system) #~%standard-phases
+         #~(modify-phases %standard-phases
+             (add-after 'unpack 'set-PKG_CONFIG
+               (lambda _
+                 (setenv "PKG_CONFIG" #$(pkg-config-for-target))))))))
    (synopsis "PDF rendering library")
    (description
     "Poppler is a PDF rendering library based on the xpdf-3.0 code base.")