summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-02-25 14:50:16 +0000
committerMarius Bakke <mbakke@fastmail.com>2020-03-29 22:34:47 +0200
commit65f61dcca258515992f279b4a2a57f6e8e4a9b9b (patch)
tree12c74007c0005b0d7dad40e01480cea449dabe0c /gnu
parentbce1e728c5c3ddb43c099333ae563f2f3c0e1f72 (diff)
downloadguix-65f61dcca258515992f279b4a2a57f6e8e4a9b9b.tar.gz
gnu: Add fogpad.
* gnu/packages/music.scm (fogpad): New variable.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 23fc67a2e9..5f9060f54e 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5357,3 +5357,29 @@ standalone JACK application.")
 This is an unofficial port of the Regrader plugin created by Igorski.  It
 is available as an LV2 plugin and a standalone JACK application.")
     (license license:expat)))
+
+(define-public fogpad
+  (package
+    (inherit vl1-emulator)
+    (name "fogpad")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/linuxmao-org/fogpad")
+             (commit (string-append "v" version))
+             ;; bundles a specific commit of the DISTRHO plugin framework
+             (recursive? #t)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "1j1hbya2dsqpf22zkpi4kwz3dram9g1ndxzmgfwpmf3i4jd3csgb"))))
+    (home-page "https://github.com/linuxmao-org/fogpad")
+    (synopsis "Reverb effect plugin")
+    (description
+     "Fogpad is a reverb effect in which the reflections can be frozen,
+filtered, pitch shifted and ultimately disintegrated.  This is an unofficial
+port of the Regrader plugin created by Igorski.  It is available as an LV2
+plugin and a standalone JACK application.")
+    (license license:expat)))