summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 15:47:52 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-02-14 18:16:07 +0100
commit66377fdced522d2798ce6846f1b035a7f20ab574 (patch)
treeb0e3a8fd4d41a3c87027225ad3454345a39b2387 /gnu
parent7bef8fd5cf849ca3732e03632f40fa253599ae0a (diff)
downloadguix-66377fdced522d2798ce6846f1b035a7f20ab574.tar.gz
gnu: tmuxifier: Don't use unstable tarball.
* gnu/packages/tmux.scm (tmuxifier)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tmux.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/tmux.scm b/gnu/packages/tmux.scm
index fc2871e0f3..e09e6c1fbe 100644
--- a/gnu/packages/tmux.scm
+++ b/gnu/packages/tmux.scm
@@ -95,14 +95,14 @@ continue running in the background, then later reattached.")
     (name "tmuxifier")
     (version "0.13.0")
     (source (origin
-             (method url-fetch)
-             (uri (string-append
-                    "https://github.com/jimeh/tmuxifier/archive/v"
-                    version ".tar.gz"))
-             (file-name (string-append name "-" version ".tar.gz"))
+             (method git-fetch)
+             (uri (git-reference
+                   (url "https://github.com/jimeh/tmuxifier.git")
+                   (commit (string-append "v" version))))
+             (file-name (git-file-name name version))
              (sha256
               (base32
-               "1j9fj6zg0j3sdn7svpybzsqh7876rv81zi437976kj7hxnyjkcz7"))))
+               "1b6a1cw2mnml84k5vhbcp58kvp94xlnlpp4kwdhqw4jrzfgcjfzd"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f