summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndrew Jose <arnav.jose@gmail.com>2023-09-21 18:14:56 +0530
committerEfraim Flashner <efraim@flashner.co.il>2023-09-28 21:17:20 +0300
commit66c18d23da3e88b3ba278346c1372c8529ddb7e2 (patch)
tree0532c29f1a1723d7d1b4ea094da7e587824b1e96 /gnu
parent87a216a516a3bc9fdae685eec8cdd7ad6c33e96b (diff)
downloadguix-66c18d23da3e88b3ba278346c1372c8529ddb7e2.tar.gz
gnu: Add rust-temptree-0.2.
* gnu/packages/crates-io.scm (rust-temptree-0.2): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 11dc109708..7dba764950 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -67727,6 +67727,26 @@ directories.")
      "This package provides support for Linux-specific tempfile extensions.")
     (license license:expat)))
 
+(define-public rust-temptree-0.2
+  (package
+    (name "rust-temptree")
+    (version "0.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "temptree" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0c461j4xrjp1mz89fb3rmv8w36m1dm1nymv9ny60hh0v4pc99nlg"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-tempfile" ,rust-tempfile-3))))
+    (home-page "https://github.com/casey/temptree")
+    (synopsis "Temporary trees of files")
+    (description "Temporary trees of files.")
+    (license license:cc0)))
+
 (define-public rust-tendril-0.4
   (package
     (name "rust-tendril")