summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-12-10 16:20:29 +0100
committerChristopher Baines <mail@cbaines.net>2018-12-12 09:03:27 +0100
commit679c979f25e27ea559cf26e806baee4d69ece7bd (patch)
tree8db4f5f8a81903e4af70c47ff81a75f542848487 /gnu
parent053f3d48578e10e8e4be348f3ad6de539cfa2455 (diff)
downloadguix-679c979f25e27ea559cf26e806baee4d69ece7bd.tar.gz
gnu: Add python-case.
This is required to update python-amqp and python-kombu, as well as adding
python-vine.

* gnu/packages/python.scm (python-case): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4e40e3677f..e4ef234d8f 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1071,6 +1071,32 @@ for additional processing.")
 (define-public python2-capturer
   (package-with-python2 python-capturer))
 
+(define-public python-case
+  (package
+    (name "python-case")
+    (version "1.5.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "case" version))
+       (sha256
+        (base32
+         "1cagg06vfph864s6l5jb0zqliwxh647bki8j6lf4a4qrv40jnhs8"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     `(("python-mock" ,python-mock)
+       ("python-nose" ,python-nose)
+       ("python-six" ,python-six)
+       ("python-unittest2" ,python-unittest2)))
+    (native-inputs
+     `(("python-coverage" ,python-coverage)))
+    (home-page "https://github.com/celery/case")
+    (synopsis "Unittest utilities and convenience methods")
+    (description
+     "The @code{case} package provides utilities on top of unittest, including
+some helpful Python 2 compatibility convenience methods.")
+    (license license:bsd-3)))
+
 (define-public python-verboselogs
   (package
     (name "python-verboselogs")