summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-01-04 23:47:55 +0100
committerEfraim Flashner <efraim@flashner.co.il>2022-01-10 15:15:38 +0200
commit67ff1088064d3da72fe8942ad62a53f7c41c7e04 (patch)
tree5e957df13930d5f5b87501494097d2ee6919904b /gnu
parent782eaa180e4815c560ffc622b02f82cc0d7079b1 (diff)
downloadguix-67ff1088064d3da72fe8942ad62a53f7c41c7e04.tar.gz
gnu: Add julia-bioalignments.
* gnu/packages/julia-xyz.scm (julia-bioalignments): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 5185832765..f358780b31 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -361,6 +361,41 @@ code easy by supplying a framework for writing and running groups of
 benchmarks as well as comparing benchmark results.")
     (license license:expat)))
 
+(define-public julia-bioalignments
+  (package
+    (name "julia-bioalignments")
+    (version "2.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/BioJulia/BioAlignments.jl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1wf6qgsada59r2fykxfj9hcr635wl8maqxbd3w8qpa01k9glxa0k"))))
+    (build-system julia-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'skip-test
+           (lambda _
+             ;; Test fails because an unexpected type representation from
+             ;; BioSequences.  The aligned value is correct though.
+             (substitute* "test/runtests.jl"
+               (("@test sprint\\(show, aln\\)")
+                "@test_broken sprint(show, aln)")))))))
+    (propagated-inputs
+     (list julia-biogenerics
+           julia-biosequences
+           julia-biosymbols
+           julia-intervaltrees))
+    (home-page "https://github.com/BioJulia/BioAlignments.jl")
+    (synopsis "Sequence alignement algorithm and data structures")
+    (description "This package provides alignement algorithms and data
+structures for sequence of DNA, RNA, and amino acid sequences.")
+    (license license:expat)))
+
 (define-public julia-biogenerics
   ;; No upstream release
   (let ((commit "a75abaf459250e2b5e22b4d9adf25fd36d2acab6")