summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-07 12:35:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-07 12:35:00 +0100
commit6874994fa9b2b811acef5e875002b026724ae220 (patch)
treeb573495ab670f10aac7a7f8e7014a6031e23e893 /gnu
parentc25a6d39f3f593bdda01533f923d83f375bb0f6c (diff)
downloadguix-6874994fa9b2b811acef5e875002b026724ae220.tar.gz
gnu: Add python-pytest-rerunfailures.
* gnu/packages/python-check.scm (python-pytest-rerunfailures): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-check.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index cb598b0344..d261ccac68 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1859,6 +1859,24 @@ The purpose of this package is to provide an easy way to test asynchronous
 HTTP requests.")
     (license license:expat)))
 
+(define-public python-pytest-rerunfailures
+  (package
+    (name "python-pytest-rerunfailures")
+    (version "10.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "pytest-rerunfailures" version))
+       (sha256
+        (base32 "15v68kggjvkflbqr0vz8gp5yp3pcsk0rz05bpg2l4xp0a6nin7ly"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pytest python-setuptools))
+    (home-page "https://github.com/pytest-dev/pytest-rerunfailures")
+    (synopsis "Pytest plugin to re-run flaky tests")
+    (description "This package provides a pytest plugin to re-run tests to
+eliminate flaky failures.")
+    (license license:mpl2.0)))
+
 (define-public python-xunitparser
   (package
     (name "python-xunitparser")