summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 11:17:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-14 12:19:42 +0200
commit689769961124cc75345175e42c46cfd65da57b19 (patch)
tree399fe55f3e7b322d590653ee39b71af6570322c6 /gnu
parente72b40af3ea4403d07aa80b93edc790e07074762 (diff)
downloadguix-689769961124cc75345175e42c46cfd65da57b19.tar.gz
gnu: Add perl-test-subcalls.
* gnu/packages/perl-check.scm (perl-test-subcalls): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index ac80edc8da..0aaae65573 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -1316,6 +1316,33 @@ makes fork(2) safe to use in test cases.")
     (home-page "https://metacpan.org/release/Test-Simple")
     (license perl-license)))
 
+(define-public perl-test-subcalls
+  (package
+    (name "perl-test-subcalls")
+    (version "1.10")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+                           "Test-SubCalls-" version ".tar.gz"))
+       (sha256
+        (base32 "1hmnv9nkdzyrr6yis0dnkf4lk0hwld3zapiyq7mizrq5barykhfb"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-hook-lexwrap" ,perl-hook-lexwrap)))
+    (home-page "https://metacpan.org/release/Test-SubCalls")
+    (synopsis "Track the number of times subs are called")
+    (description
+     "There are a number of different situations (like testing caching
+code) where you want to want to do a number of tests, and then verify
+that some underlying subroutine deep within the code was called
+a specific number of times.
+
+Test::SubCalls module provides a number of functions for doing testing
+in this way in association with your normal Test::More (or similar)
+test scripts.")
+    (license perl-license)))
+
 (define-public perl-test-taint
   (package
     (name "perl-test-taint")