summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRutger Helling <rhelling@mykolab.com>2018-01-02 11:33:16 +0100
committerRutger Helling <rhelling@mykolab.com>2018-01-02 11:39:57 +0100
commit68e4921130a9ff8231e971df06dbe4a71998165c (patch)
tree47bab57ce10479cae73d96e9ab102c7350469bc1 /gnu
parent95c45e53497e30af28bdfd6947801731c9d9f27b (diff)
downloadguix-68e4921130a9ff8231e971df06dbe4a71998165c.tar.gz
gnu: wine64: Copy missing man file.
* gnu/packages/wine.scm (wine64)[arguments]: Copy missing man file from "wine"
input. Clarify 'copy-wine32-files phase with comments.
[synopsis]: Use proper "WoW64" term.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/wine.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/wine.scm b/gnu/packages/wine.scm
index 28e6f55b12..91aa56de4c 100644
--- a/gnu/packages/wine.scm
+++ b/gnu/packages/wine.scm
@@ -175,6 +175,7 @@ integrate Windows applications into your desktop.")
        (modify-phases %standard-phases
          (add-after 'install 'copy-wine32-files
            (lambda* (#:key outputs #:allow-other-keys)
+             ;; Copy the 32-bit binaries needed for WoW64.
              (copy-file (string-append (assoc-ref %build-inputs "wine")
                                        "/bin/wine") (string-append (assoc-ref
                                        %outputs "out") "/bin/wine"))
@@ -182,6 +183,12 @@ integrate Windows applications into your desktop.")
                                        "/bin/wine-preloader") (string-append
                                        (assoc-ref %outputs "out")
                                        "/bin/wine-preloader"))
+             ;; Copy the missing man file for the wine binary from wine.
+             (system (string-append "gunzip < " (string-append (assoc-ref
+                                    %build-inputs "wine")
+                                    "/share/man/man1/wine.1.gz") "> "
+                                    (string-append (assoc-ref %outputs "out")
+                                    "/share/man/man1/wine.1")))
              #t))
          (add-after 'configure 'patch-dlopen-paths
            ;; Hardcode dlopened sonames to absolute paths.
@@ -200,7 +207,7 @@ integrate Windows applications into your desktop.")
        ,@(strip-keyword-arguments '(#:configure-flags #:make-flags #:phases
                                     #:system)
                                   (package-arguments wine))))
-    (synopsis "Implementation of the Windows API (WOW64 version)")
+    (synopsis "Implementation of the Windows API (WoW64 version)")
     (supported-systems '("x86_64-linux" "aarch64-linux"))))
 
 ;; TODO: This is wine development version, provided for historical reasons.