summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2017-08-29 19:48:38 +0200
committerAndy Wingo <wingo@igalia.com>2017-08-29 19:52:16 +0200
commit69dcad33c883a9004111842643a295d94ffe9e60 (patch)
treed921b2432e1a8be028041d84d90f2475f49cee4d /gnu
parent84d9abe4503ff47d8934e962fc8f85c75cdcd0fd (diff)
downloadguix-69dcad33c883a9004111842643a295d94ffe9e60.tar.gz
gnu: emacs-lua-mode: Update to current git.
* gnu/packages/emacs.scm (emacs-lua-mode): Update; fixes a very annoying bug
with syntax highlighting of multi-line strings.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm38
1 files changed, 20 insertions, 18 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 71eb5a03ce..7555a4f66a 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -3561,25 +3561,27 @@ CIDER).")
     (license license:gpl3+)))
 
 (define-public emacs-lua-mode
-  (package
-    (name "emacs-lua-mode")
-    (version "20151025")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/immerrr/lua-mode/archive/v"
-                    version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "0sbhfny5ib65cnx6xcy6h9bbw27mw034s8m9cca00bhxqaqi6p4v"))))
-    (build-system emacs-build-system)
-    (home-page "https://github.com/immerrr/lua-mode/")
-    (synopsis "Major mode for lua")
-    (description
-     "This Emacs package provides a mode for @uref{https://www.lua.org/,
+  (let ((commit "652e299cb967fccca827dda381d61a9c144d97de")
+        (revision "1"))
+    (package
+      (name "emacs-lua-mode")
+      (version (string-append "20151025." revision "-" (string-take commit 9)))
+      (home-page "https://github.com/immerrr/lua-mode/")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit commit)))
+                (file-name (string-append name "-" version ".checkout"))
+                (sha256
+                 (base32
+                  "053025k930wh0lak6rc1973ynfrmm8zsyzfqhhd39x7abkl41hc9"))))
+      (build-system emacs-build-system)
+      (synopsis "Major mode for lua")
+      (description
+       "This Emacs package provides a mode for @uref{https://www.lua.org/,
 Lua programing language}.")
-    (license license:gpl2+)))
+      (license license:gpl2+))))
 
 (define-public emacs-ebuild-mode
   (package