summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-04 12:07:44 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:23 +0200
commit6a2ce347eec8137f1f251ff979648f8d16ff4e5c (patch)
tree9f8d01819d7dae3eba715af98db0ff28fd430a18 /gnu
parent2f452f5e2d04b24f0dd054f9a8f48249b6cebb04 (diff)
downloadguix-6a2ce347eec8137f1f251ff979648f8d16ff4e5c.tar.gz
gnu: Add rust-glow-0.12.
* gnu/packages/crates-graphics.scm (rust-glow-0.12): New variable.

Change-Id: I55909982ddbeafcafd586ffbae96e8759a031bc7
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-graphics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index c5600f3039..5a66e8bd04 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -1366,6 +1366,31 @@ EUI-64, also known as MAC-48 media access control addresses.")
      "Generated OpenGL bindings and wrapper for Servo.")
     (license (list license:asl2.0 license:expat))))
 
+(define-public rust-glow-0.12
+  (package
+    (name "rust-glow")
+    (version "0.12.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "glow" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0a1p6c9nff09m4gn0xnnschcpjq35y7c12w69ar8l2mnwj0fa3ya"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-js-sys" ,rust-js-sys-0.3)
+                       ("rust-log" ,rust-log-0.4)
+                       ("rust-slotmap" ,rust-slotmap-1)
+                       ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
+                       ("rust-web-sys" ,rust-web-sys-0.3))))
+    (home-page "https://github.com/grovesNL/glow.git")
+    (synopsis "Bindings to run GL anywhere")
+    (description
+     "GL on Whatever: a set of bindings to run GL (Open GL, @code{OpenGL} ES, and
+@code{WebGL}) anywhere, and avoid target-specific code.")
+    (license (list license:expat license:asl2.0 license:zlib))))
+
 (define-public rust-glutin-0.31
   (package
     (name "rust-glutin")