summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 16:45:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 17:13:52 +0100
commit6a5bfe09ebfeff74b462e9260f5d902c86f88a61 (patch)
tree5d8368591559355e4527ce0e9376f3c6a1d072a4 /gnu
parent1ea708af8cf89c15a508941d6af6ee36e401a3ed (diff)
downloadguix-6a5bfe09ebfeff74b462e9260f5d902c86f88a61.tar.gz
gnu: Add r-longitudinal.
* gnu/packages/cran.scm (r-longitudinal): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index e2ad3ca03f..e420d2eb66 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10099,3 +10099,25 @@ package \"boot\".")
 Kaplan-Meier (KM) or Nearest Neighbor Estimation (NNE) method of Heagerty,
 Lumley & Pepe (Biometrics, Vol 56 No 2, 2000, PP 337-344)")
     (license license:gpl2+)))
+
+(define-public r-longitudinal
+  (package
+    (name "r-longitudinal")
+    (version "1.1.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "longitudinal" version))
+       (sha256
+        (base32
+         "1d83ws28nxi3kw5lgd5n5y7865djq7ky72fw3ddi1fkkhg1r9y6l"))))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-corpcor" ,r-corpcor)))
+    (home-page "http://strimmerlab.org/software/longitudinal/")
+    (synopsis "Analysis of multiple time course data")
+    (description
+     "This package contains general data structures and functions for
+longitudinal data with multiple variables, repeated measurements, and
+irregularly spaced time points.  It also implements a shrinkage estimator of
+dynamical correlation and dynamical covariance.")
+    (license license:gpl3+)))