summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Pflug <david@pflug.io>2024-01-27 09:41:58 -0500
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-10 15:05:49 +0000
commit6aefab6c0c5e9656572ce0ad8d9d41e27cb17071 (patch)
treed508c3903c99491b7286fdbfa62449fcc7732138 /gnu
parent9ffdcb249278d9bb95ffb6c6e9f94b675bb1068c (diff)
downloadguix-6aefab6c0c5e9656572ce0ad8d9d41e27cb17071.tar.gz
gnu: odamex: Update to 10.4.0.
* gnu/packages/games.scm (odamex): Update to 10.4.0.
[inputs]: Add fltk, jsoncpp, libpng, miniupnpc, portmidi and protobuf.

Change-Id: I371d18498640e15a7bfae527fea12d9432368f50
Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 63198712d8..260fd08cfc 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -60,7 +60,7 @@
 ;;; Copyright © 2021 Olivier Rojon <o.rojon@posteo.net>
 ;;; Copyright © 2021 Stefan Reichör <stefan@xsteve.at>
 ;;; Copyright © 2021, 2022 Greg Hogan <code@greghogan.com>
-;;; Copyright © 2021 David Pflug <david@pflug.io>
+;;; Copyright © 2021, 2024 David Pflug <david@pflug.io>
 ;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2021 Solene Rapenne <solene@perso.pw>
 ;;; Copyright © 2021, 2022 Noisytoot <ron@noisytoot.org>
@@ -8096,26 +8096,31 @@ Strife, Chex Quest, and fan-created games like Harmony, Hacx and Freedoom.")
 (define-public odamex
   (package
     (name "odamex")
-    (version "0.9.5")
+    (version "10.4.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append
              "mirror://sourceforge/odamex/Odamex/" version "/"
-             "odamex-src-" version ".tar.bz2"))
+             "odamex-src-" version ".tar.xz"))
        (sha256
-        (base32 "1x0c9vnwn336inkfamh4na8xjyfjmzfxfn49j4snqymkypjqw6jq"))))
+        (base32 "1isrmki18471yry48mmm7lxzp1kiqma9cc7fx38cvpm2mpgfyvzk"))))
     (build-system cmake-build-system)
     (arguments `(#:tests? #f))          ; no tests
     (native-inputs
      (list deutex))
     (inputs
-     `(("sdl" ,sdl2)
-       ("sdl-mixer" ,sdl2-mixer)
-       ("zlib" ,zlib)
-       ("libpng" ,libpng)
+     `(("alsa-lib" ,alsa-lib)
        ("curl" ,curl)
-       ("alsa-lib" ,alsa-lib)))
+       ("fltk" ,fltk)
+       ("jsoncpp" ,jsoncpp)
+       ("libpng" ,libpng)
+       ("miniupnpc" ,miniupnpc)
+       ("portmidi" ,portmidi)
+       ("protobuf" ,protobuf)
+       ("sdl" ,sdl2)
+       ("sdl-mixer" ,sdl2-mixer)
+       ("zlib" ,zlib)))
     (home-page "https://odamex.net/")
     (synopsis "Multiplayer Doom port")
     (description "Odamex is a modification of the Doom engine that