summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-01 16:02:45 -0400
committerLeo Famulari <leo@famulari.name>2017-07-01 16:08:47 -0400
commit6b820ef15d532a3d0016be657a99d88377c7e03c (patch)
tree33414ef13b990d0bd23603fbb3bc90f72b770a7c /gnu
parent5e1f9b304285cacea2997045f5a4cc41ea0f9762 (diff)
downloadguix-6b820ef15d532a3d0016be657a99d88377c7e03c.tar.gz
Revert "gnu: guile-rsvg: Update to commit 05c6a2fd."
This reverts commit 0fd8013fcaafa9f53c7e304b2573c0314471df89.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm78
-rw-r--r--gnu/packages/patches/guile-rsvg-pkgconfig.patch2
2 files changed, 37 insertions, 43 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index a02e885f56..bb80ef6418 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -813,49 +813,43 @@ exceptions, macros, and a dynamic programming environment.")
     (license license:lgpl3+)))
 
 (define-public guile-rsvg
-  ;; Use a recent snapshot that supports Guile 2.2 and beyond.
-  (let ((commit "05c6a2fd67e4fea1a7c3ff776729dc931bae6678")
-        (revision "0"))
-    (package
-      (name "guile-rsvg")
-      (version (string-append "2.18.1-" revision "."
-                              (string-take commit 7)))
-      (source (origin
-                (method url-fetch)
-                (uri (string-append "https://gitlab.com/wingo/guile-rsvg/"
-                                    "repository/archive.tar.gz?ref="
-                                    commit))
-                (sha256
-                 (base32
-                  "0vdzjx8l5nc4y2xjqs0g1rqn1zrwfsm30brh5gz00r1x41a2pvv2"))
-                (patches (search-patches "guile-rsvg-pkgconfig.patch"))
-                (modules '((guix build utils)))
-                (snippet
-                 '(substitute* (find-files "." "Makefile\\.am")
-                    (("/share/guile/site")
-                     "/share/guile/site/@GUILE_EFFECTIVE_VERSION@")))
-                (file-name (string-append name "-" version ".tar.gz"))))
-      (build-system gnu-build-system)
-      (arguments
-       `(#:phases (modify-phases %standard-phases
-                    (add-before 'configure 'bootstrap
-                      (lambda _
-                        (zero? (system* "autoreconf" "-vfi")))))))
-      (native-inputs `(("pkg-config" ,pkg-config)
-                       ("autoconf" ,autoconf)
-                       ("automake" ,automake)
-                       ("libtool" ,libtool)
-                       ("texinfo" ,texinfo)))
-      (inputs `(("guile" ,guile-2.0)
-                ("librsvg" ,librsvg)
-                ("guile-lib" ,guile2.0-lib)))        ;for (unit-test)
-      (propagated-inputs `(("guile-cairo" ,guile-cairo)))
-      (synopsis "Render SVG images using Cairo from Guile")
-      (description
-       "Guile-RSVG wraps the RSVG library for Guile, allowing you to render SVG
+  (package
+    (name "guile-rsvg")
+    (version "2.18.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://wingolog.org/pub/guile-rsvg/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "136f236iw3yrrz6pkkp1ma9c5mrs5icqha6pnawinqpk892r3jh7"))
+              (patches (search-patches "guile-rsvg-pkgconfig.patch"))
+              (modules '((guix build utils)))
+              (snippet
+               '(substitute* (find-files "." "Makefile\\.am")
+                  (("/share/guile/site")
+                   "/share/guile/site/2.0")))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases (modify-phases %standard-phases
+                  (add-before 'configure 'bootstrap
+                              (lambda _
+                                (zero? (system* "autoreconf" "-vfi")))))))
+    (native-inputs `(("pkg-config" ,pkg-config)
+                     ("autoconf" ,autoconf)
+                     ("automake" ,automake)
+                     ("libtool" ,libtool)
+                     ("texinfo" ,texinfo)))
+    (inputs `(("guile" ,guile-2.0)
+              ("librsvg" ,librsvg)
+              ("guile-lib" ,guile2.0-lib)))          ;for (unit-test)
+    (propagated-inputs `(("guile-cairo" ,guile-cairo)))
+    (synopsis "Render SVG images using Cairo from Guile")
+    (description
+     "Guile-RSVG wraps the RSVG library for Guile, allowing you to render SVG
 images onto Cairo surfaces.")
-      (home-page "http://wingolog.org/projects/guile-rsvg/")
-      (license license:lgpl2.1+))))
+    (home-page "http://wingolog.org/projects/guile-rsvg/")
+    (license license:lgpl2.1+)))
 
 (define-public guile-present
   (package
diff --git a/gnu/packages/patches/guile-rsvg-pkgconfig.patch b/gnu/packages/patches/guile-rsvg-pkgconfig.patch
index 51483a3472..2272b4e1cd 100644
--- a/gnu/packages/patches/guile-rsvg-pkgconfig.patch
+++ b/gnu/packages/patches/guile-rsvg-pkgconfig.patch
@@ -9,7 +9,7 @@ and LDFLAGS for Guile would not be captured.
  
 +dnl The above macro fails to set the 'GUILE_CFLAGS' and 'GUILE_LIBS'
 +dnl substitution variables, hence this line.
-+PKG_CHECK_MODULES(GUILE, guile-$GUILE_EFFECTIVE_VERSION)
++PKG_CHECK_MODULES(GUILE, guile-2.0)
 +
  PKG_CHECK_MODULES(GUILE_CAIRO, guile-cairo >= 1.4.0)
  AC_SUBST(GUILE_CAIRO_LIBS)