summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorValentin Ignatev <valentignatev@gmail.com>2020-01-15 03:04:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-02-09 11:03:57 +0200
commit6dd06d9656d4bd1c7e5076baf20a4dce0a97da6c (patch)
tree6522453e299c3cc295ddded2be8d8bc624acd295 /gnu
parent5467e3441846c7555ebf67ecc7036a1447ff5db8 (diff)
downloadguix-6dd06d9656d4bd1c7e5076baf20a4dce0a97da6c.tar.gz
gnu: Add rust-compiler-error-0.1.
* gnu/packages/crates-io.scm (rust-compiler-error-0.1): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 0ff2f9828a..52a4630c8b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1639,6 +1639,26 @@ need compiler-rt intrinsics.")
     (license (list license:asl2.0
                    license:expat))))
 
+(define-public rust-compiler-error-0.1
+  (package
+    (name "rust-compiler-error")
+    (version "0.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "compiler_error" version))
+       (file-name
+        (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0irh7c0gznk2k6mj3cmqw7x4pg59lppmy1y8d6k5xc926rnmz5zg"))))
+    (build-system cargo-build-system)
+    (arguments '(#:skip-build? #t))
+    (home-page "https://github.com/lu-zero/compiler_error")
+    (synopsis "Triggerable compiler error")
+    (description "This package provides a triggerable compiler error for Rust.")
+    (license license:expat)))
+
 (define-public rust-compiletest-rs-0.3
   (package
     (name "rust-compiletest-rs")