summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-06-15 19:09:46 +0200
committerjgart <jgart@dismail.de>2024-06-26 01:37:27 -0500
commit6ddb855f988c33c83d7781517bbf4763c5f77928 (patch)
tree7dcbe55ca87678af01689aa4523cf39e6d6f7b88 /gnu
parent89fb7c2784a3fbbf78863660c92e87b2d11c0016 (diff)
downloadguix-6ddb855f988c33c83d7781517bbf4763c5f77928.tar.gz
gnu: Add python-spin.
* gnu/packages/python-science.scm (python-spin): New variable.

Change-Id: I794845d559f3f4f3ab9cf98b0e4a4321b470f7f8
Signed-off-by: jgart <jgart@dismail.de>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-science.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 58b7f3b3ee..82089da775 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1495,6 +1495,32 @@ evaluating arrays of polynomials based on @code{numpy.ndarray objects}.")
     (supported-systems '("x86_64-linux" "aarch64-linux" "powerpc64le-linux"))
     (license license:bsd-2)))
 
+(define-public python-spin
+  (package
+  (name "python-spin")
+  (version "0.8")
+  (source
+   (origin
+     (method url-fetch)
+     (uri (pypi-uri "spin" version))
+     (sha256
+      (base32 "0ff48nagfaai3j26g1db4zq2bwdv6kj5l7xhcs2l9kzg7qzrmhr7"))))
+  (build-system pyproject-build-system)
+  (propagated-inputs (list python-click python-colorama python-tomli))
+  (native-inputs (list python-pytest))
+  (home-page "https://github.com/scientific-python/spin")
+  (synopsis "Developer tool for scientific Python libraries")
+  (description "@code{spin} is a simple interface for common development
+tasks.  It comes with a few common build commands out the box, but can
+easily be customized per project.
+
+The impetus behind developing the tool was the mass migration of scientific
+Python libraries (SciPy, scikit-image, and NumPy, etc.) to Meson, after
+distutils was deprecated.  When many of the build and installation commands
+changed, it made sense to abstract away the nuisance of having to re-learn
+them.")
+  (license license:bsd-3)))
+
 (define-public python-baycomp
   (package
     (name "python-baycomp")