summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-03 22:09:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-10 10:40:42 +0200
commit6e2417509da798380b40fba25102bd3cd8d9ffae (patch)
tree3b3b710f87cdc8a6e8c3ba79220bd4b16f3ec178 /gnu
parent52915062b9a5af4a1663a2d39f88626d9f3fc29d (diff)
downloadguix-6e2417509da798380b40fba25102bd3cd8d9ffae.tar.gz
gnu: Add scroll.
* gnu/packages/haskell-apps.scm (scroll): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell-apps.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 361ab9f5fc..144ff9eb32 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -599,6 +599,37 @@ proved to be an excellent learning experience for the programmers.  Everything
 is programmed in Haskell.")
     (license license:bsd-3)))
 
+(define-public scroll
+  (package
+    (name "scroll")
+    (version "1.20180421")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://hackage.haskell.org/package/scroll/scroll-"
+               version ".tar.gz"))
+        (sha256
+         (base32
+          "0apzrvf99rskj4dbmn57jjxrsf19j436s8a09m950df5aws3a0wj"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-case-insensitive" ,ghc-case-insensitive)
+       ("ghc-data-default" ,ghc-data-default)
+       ("ghc-ifelse" ,ghc-ifelse)
+       ("ghc-monad-loops" ,ghc-monad-loops)
+       ("ghc-ncurses" ,ghc-ncurses)
+       ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+       ("ghc-random" ,ghc-random)
+       ("ghc-vector" ,ghc-vector)))
+    (home-page "https://joeyh.name/code/scroll/")
+    (synopsis "scroll(6), a roguelike game")
+    (description
+     "You're a bookworm that's stuck on a scroll.  You have to dodge between
+words and use spells to make your way down the page as the scroll is read.  Go
+too slow and you'll get wound up in the scroll and crushed.")
+    (license license:gpl2)))
+
 (define-public shellcheck
   (package
     (name "shellcheck")