summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 15:49:53 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:59 +0200
commit6e33208a28dd6edf284d22d35df13b6065fe5dc0 (patch)
treec9b6c6a7221c8c2aad29f141a2766fafc4044a3f /gnu
parent50e433f08c49652fe9c236edca2bf7665e8e4531 (diff)
downloadguix-6e33208a28dd6edf284d22d35df13b6065fe5dc0.tar.gz
gnu: Add texlive-interchar.
* gnu/packages/tex.scm (texlive-interchar): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 974434859b..dda8135b2e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5837,6 +5837,27 @@ between various classes of Unix systems.")
 
 (define-deprecated-package texlive-latex-ifplatform texlive-ifplatform)
 
+(define-public texlive-interchar
+  (package
+    (name "texlive-interchar")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/xelatex/interchar/"
+                   "tex/xelatex/interchar/")
+             (base32
+              "06pvpaph1gi3rjvwzpvzc2rlx0wb8fqmidbfh8dw2qazzbirdlnz")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/interchar")
+    (synopsis "Managing character class schemes in XeTeX")
+    (description
+     "The package manages character class schemes of XeTeX.  Using this
+package, you may switch among different character class schemes.  Migration
+commands are provided for make packages using this mechanism compatible with
+each others.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-latexmk
   (package
     (name "texlive-latexmk")