summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-29 15:58:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-31 22:05:22 +0200
commit6e4f1f863685da7dc2fe129249438b5f6885ac52 (patch)
tree884152a854849857b922b45a620d4684b77786d7 /gnu
parent713ce9c39ce1c706257c6772491debd4f9ad4e99 (diff)
downloadguix-6e4f1f863685da7dc2fe129249438b5f6885ac52.tar.gz
gnu: Add texlive-progress.
* gnu/packages/tex.scm (texlive-progress): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e8c155de68..86461f526e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -93029,6 +93029,27 @@ problems they cover.")
 environment is available for fragments that must not break with the pages.")
     (license license:gpl3)))
 
+(define-public texlive-progress
+  (package
+    (name "texlive-progress")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/progress/" "tex/latex/progress/")
+             (base32
+              "14sfbs9d3b28xqqaxzv7wcyjk60gqy30zwpl91mz0g55xxng7y6r")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/progress")
+    (synopsis "Creates an overview of a document's state")
+    (description
+     "Progress is a package which, when compiling TeX and LaTeX documents,
+generates a HTML file showing an overview of a document's state (of how
+finished it is).  The report is sent to file @code{\\ProgressReportName},
+which is by default the @code{\\jobname} with the date appended (but is
+user-modifiable).")
+    (license license:lppl)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar