summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-17 19:21:59 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-14 19:37:50 +0300
commit6e60270317be77a9affc3abc2d14907fee939d54 (patch)
treef74a86c963a787bf2d2e40df8cdd1d112fa2891f /gnu
parent9d1654b96d1c0dc9359983c062f4c669d3d6443c (diff)
downloadguix-6e60270317be77a9affc3abc2d14907fee939d54.tar.gz
gnu: Remove rust-postgres-0.15.
* gnu/packages/crates-io.scm (rust-postgres-0.15): Delete variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 61e99cc930..6d889c3227 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45505,34 +45505,6 @@ overloading without macros in Rust.")
      "This package provides a native, synchronous PostgreSQL client.")
     (license license:expat)))
 
-(define-public rust-postgres-0.15
-  (package
-    (inherit rust-postgres-0.19)
-    (name "rust-postgres")
-    (version "0.15.2")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "postgres" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "1id6jb56jack7kxivpp3rnjjmkmymmxqadf0h0smgbsixy8dwp8i"))))
-    (build-system cargo-build-system)
-    (arguments
-     `(#:skip-build? #t
-       #:cargo-inputs
-       (("rust-bytes" ,rust-bytes-0.4)
-        ("rust-fallible-iterator" ,rust-fallible-iterator-0.1)
-        ("rust-log" ,rust-log-0.4)
-        ("rust-native-tls" ,rust-native-tls-0.1)
-        ("rust-openssl" ,rust-openssl-0.9)
-        ("rust-postgres-protocol" ,rust-postgres-protocol-0.3)
-        ("rust-postgres-shared" ,rust-postgres-shared-0.4)
-        ("rust-rustc-serialize" ,rust-rustc-serialize-0.3)
-        ("rust-schannel" ,rust-schannel-0.1)
-        ("rust-security-framework" ,rust-security-framework-0.1)
-        ("rust-socket2" ,rust-socket2-0.3))))))
-
 (define-public rust-postgres-derive-0.4
   (package
     (name "rust-postgres-derive")