summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-19 15:38:10 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-20 22:47:02 -0500
commit6e6b1571b8b5b06c88cde2ce7d2f43e23b2fd03e (patch)
tree36145b2b2fc48817dfce3b14b25152e5bebbef31 /gnu
parent48ca8dbabd6fc749155e31795e03471de6ee9291 (diff)
downloadguix-6e6b1571b8b5b06c88cde2ce7d2f43e23b2fd03e.tar.gz
gnu: python2-gevent: Remove package.
* gnu/packages/python-xyz.scm (python2-gevent): Remove variable.
(python-gevent)[properties]: Remove field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7173a05aba..a4fa60d27b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12635,17 +12635,7 @@ graphviz.")
      "@code{gevent} is a coroutine-based Python networking library that uses
 @code{greenlet} to provide a high-level synchronous API on top of the
 @code{libev} event loop.")
-    (license license:expat)
-    (properties `((python2-variant . ,(delay python2-gevent))))))
-
-(define-public python2-gevent
-  (let ((base (package-with-python2
-               (strip-python2-variant python-gevent))))
-    (package
-      (inherit base)
-      (native-inputs `(,@(package-native-inputs base)
-                       ("python-mock" ,python2-mock)
-                       ("python2-selectors2" ,python2-selectors2))))))
+    (license license:expat)))
 
 (define-public python-fastimport
   (package