summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-24 00:33:38 -0400
committerLeo Famulari <leo@famulari.name>2017-10-24 10:21:51 -0400
commit6ee4fd2ae18523088bf8d703ea78a5729202828e (patch)
treec93dbbbc5bd14e8882b778d7f64e5e24d78f734c /gnu
parentdb4411b42b902c79351aa704ce3949c48f1be29b (diff)
downloadguix-6ee4fd2ae18523088bf8d703ea78a5729202828e.tar.gz
gnu: borg: Split up the monolithic man page.
* gnu/packages/backup.scm (borg)[arguments]: Rewrite 'install-docs'
phase to install one man page per Borg sub-command.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/backup.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 9de120bf26..55d5ede040 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -519,7 +519,7 @@ detection, and lossless compression.")
                             "and not test_fuse "
                             "and not test_fuse_allow_damaged_files"))))))
          (add-after 'install 'install-doc
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda* (#:key inputs outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
                     (man (string-append out "/share/man/man1"))
                     (misc (string-append out "/share/borg/misc")))
@@ -527,11 +527,11 @@ detection, and lossless compression.")
                          '("docs/misc/create_chunker-params.txt"
                            "docs/misc/internals-picture.txt"
                            "docs/misc/prune-example.txt"))
+               (add-installed-pythonpath inputs outputs)
                (and
-                 (zero? (system* "python3" "setup.py" "build_ext" "--inplace"))
-                 (zero? (system* "make" "-C" "docs" "man"))
+                 (zero? (system* "python3" "setup.py" "build_man"))
                  (begin
-                   (install-file "docs/_build/man/borg.1" man)
+                   (copy-recursively "docs/man" man)
                    #t))))))))
     (native-inputs
      `(("python-cython" ,python-cython)