summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-06-03 12:46:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-06-03 12:46:11 +0300
commit6f5c67d7250913bde52f47904fda08325a9334a3 (patch)
treeb027fee726aa1d786c82c2a3f1e5750cf693cff4 /gnu
parent2c790226d22f86b641191918462fa7527c8a3ac7 (diff)
downloadguix-6f5c67d7250913bde52f47904fda08325a9334a3.tar.gz
gnu: keepassxc: Fix compilation with Qt 5.11.
* gnu/packages/password-utils.scm (keepassxc)[arguments]: Add custom
'patch-sources phase to include missing headers.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/password-utils.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 011cf594d1..497963af63 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
-;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
 ;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
 ;;; Copyright © 2016 Jessica Tallon <tsyesika@tsyesika.se>
@@ -110,7 +110,17 @@ human.")
     (arguments
      '(#:configure-flags '("-DWITH_XC_NETWORKING=YES"
                            "-DWITH_XC_BROWSER=YES"
-                           "-DWITH_XC_SSHAGENT=YES")))
+                           "-DWITH_XC_SSHAGENT=YES")
+       #:phases
+       (modify-phases %standard-phases
+         ;; should be fixed in 2.3.3+, see:
+         ;; https://github.com/keepassxreboot/keepassxc/pull/1964
+         (add-after 'unpack 'patch-sources
+           (lambda _
+             (substitute* "src/gui/entry/EditEntryWidget.cpp"
+               (("#include <QColorDialog>") "#include <QColorDialog>
+#include <QButtonGroup>"))
+             #t)))))
     (inputs
      `(("argon2" ,argon2)
        ("curl" ,curl) ; XC_NETWORKING