summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Graves via Guix-patches via <guix-patches@gnu.org>2024-04-11 23:10:39 +0100
committerChristopher Baines <mail@cbaines.net>2024-04-16 22:20:38 +0100
commit6feab2a48c4b64df485a1a890c617cdb36554cc2 (patch)
tree370de04bdf3b16e0b34401fe751e3785724ebbc5 /gnu
parent969c970f3806c31fe6b6f53f41af883b3804e9c2 (diff)
downloadguix-6feab2a48c4b64df485a1a890c617cdb36554cc2.tar.gz
gnu: Add perl-image-size.
* gnu/packages/perl.scm (perl-image-size): New variable.

Change-Id: Ib2b11b74451b156c4380b91334ae37032e6bb6fd
Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 80b17098c7..57a06f836b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -37,6 +37,7 @@
 ;;; Copyright © 2023 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
 ;;; Copyright © 2023 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2023 Jake Leporte <jakeleporte@outlook.com>
+;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -5554,6 +5555,25 @@ Hook::LexWrap implements wrappers in such a way that the standard
 caller function works correctly within the wrapped subroutine.")
     (license license:perl-license)))
 
+(define-public perl-image-size
+  (package
+    (name "perl-image-size")
+    (version "3.300")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RJ/RJRAY/Image-Size-"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "0sq2kwdph55h4adx50fmy86brjkkv8grsw33xrhf1k9icpwb3jak"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build))
+    (home-page "https://metacpan.org/release/Image-Size")
+    (synopsis "Extract height/width from images")
+    (description "This package provides a simple Perl library to extract
+height/width from images.")
+    (license license:perl-license)))
+
 (define-public perl-importer
   (package
     (name "perl-importer")