summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-25 12:42:11 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-25 15:13:51 +0100
commit72a758bcd37319ce2cd3c8944fecb5ca5ef449bf (patch)
treef19fedc2f56b287fb2c7120d19256b17ad25ea0e /gnu
parent6623a8151a023363b7e9312c8e38284c5fa1c10d (diff)
downloadguix-72a758bcd37319ce2cd3c8944fecb5ca5ef449bf.tar.gz
gnu: python-pyro-ppl: Skip one more test.
* gnu/packages/machine-learning.scm (python-pyro-ppl)[build-system]: Use
pyproject-build-system.
[arguments]: Remove custom 'check phase and replace with #:test-flags; disable
test_sample tests.

Change-Id: I058892451b9e5c96b077fae426a6649ce16f54c5
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/machine-learning.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 5ae210f375..3a12eb8c2f 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -4848,24 +4848,23 @@ and Numpy.")
        (file-name (git-file-name name version))
        (sha256
         (base32 "0n1vsih99pvswcaygdxkc6kq6r48ny130z6ca8pp3281396r2ykw"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
+     (list
+      #:test-flags
+      '(list "-vv" "--stage=unit"
              ;; This tests features that are only implemented when non-free
              ;; software is available (Intel MKL or CUDA).
-             (for-each delete-file
-                       (list "tests/distributions/test_spanning_tree.py"
-                             "tests/infer/mcmc/test_mcmc_api.py"))
-
+             "--ignore=tests/distributions/test_spanning_tree.py"
+             "--ignore=tests/infer/mcmc/test_mcmc_api.py"
+             ;; This test fails sometimes.
+             "--ignore=tests/optim/test_optim.py"
              ;; Four test_gamma_elbo tests fail with bad values for unknown
              ;; reasons.
-             (delete-file "tests/distributions/test_rejector.py")
-             ;; This test fails sometimes.
-             (delete-file "tests/optim/test_optim.py")
-             (invoke "pytest" "-vv" "--stage=unit"))))))
+             "--ignore=tests/distributions/test_rejector.py"
+             ;; This looks like a test system failure.  All of these fail
+             ;; because x is an array of functions, not an array of numbers.
+             "-k" "not test_sample")))
     (propagated-inputs
      (list python-numpy
            python-opt-einsum