summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-18 18:08:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:21 +0200
commit72db328ed309cd98a01366a52b9d7c30ec2b5bca (patch)
tree475adbb7e2dc116ec8c7f779af8b7c88d9d2e9b1 /gnu
parent3915064ee689ec3ce9bc5e2363101adfbe728491 (diff)
downloadguix-72db328ed309cd98a01366a52b9d7c30ec2b5bca.tar.gz
gnu: Add texlive-context-bnf.
* gnu/packages/tex.scm (texlive-context-bnf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 975cd785ce..65315c25eb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10055,6 +10055,30 @@ package.")
 environments to mark text blocks.")
     (license license:gpl3+)))
 
+(define-public texlive-context-bnf
+  (package
+    (name "texlive-context-bnf")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/context/third/bnf/"
+                   "tex/context/third/bnf/")
+             (base32
+              "0m7144pgwk1707g7na96dx4apl6il73zzcvq7qd6lmhij3m96nv8")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (propagated-inputs (list texlive-context))
+    (home-page "https://ctan.org/pkg/context-bnf")
+    (synopsis "BNF module for ConTeXt")
+    (description
+     "The module provides a simple way to write good-looking BNF-style
+grammars in ConTeXt.  Grammars are written using the BNF syntax right in your
+ConTeXt documents, so there is a clear separation between content and layout.
+This allows the user to decide exactly how the grammar is to be displayed,
+while also allowing the gist of the grammar to be understood from simply
+looking at the source ConTeXt document.")
+    (license license:gpl3+)))
+
 (define-public texlive-beamer
   (package
     (name "texlive-beamer")