summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-07-07 00:37:31 +0200
committerMarius Bakke <marius@gnu.org>2022-07-16 23:25:18 +0200
commit72e2c416beb6816091277f492a1cd4b2531a5cfc (patch)
treeba50a9b57bae35001cfc68fcc1e83f9d270a81c4 /gnu
parentb181e679e13240d29c2df0d682741c91a5c02161 (diff)
downloadguix-72e2c416beb6816091277f492a1cd4b2531a5cfc.tar.gz
gnu: jbig2dec: Remove obsolete code.
* gnu/packages/image.scm (jbig2dec)[arguments]: Remove #:phases.
[native-inputs]: Remove AUTOCONF, AUTOMAKE, and LIBTOOL.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/image.scm20
1 files changed, 3 insertions, 17 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 4d77e2d392..c8c465a39a 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -670,26 +670,12 @@ arithmetic ops.")
                (base32
                 "0dwa24kjqyg9hmm40fh048sdxfpnasz43l2rm8wlkw1qbdlpd517"))))
     (build-system gnu-build-system)
-    (arguments '(#:configure-flags '("--disable-static")
-                 #:phases (modify-phases %standard-phases
-                            (add-before 'bootstrap 'force-bootstrap
-                              (lambda _
-                                ;; XXX: jbig2dec 0.18 was released with
-                                ;; a broken configure script, so we
-                                ;; recreate the build system here.
-                                ;; Remove the autoconf inputs below
-                                ;; when deleting this code.
-                                (delete-file "configure")
-                                (delete-file "autogen.sh")
-                                #t)))))
+    (arguments '(#:configure-flags '("--disable-static")))
     (native-inputs
-     `(("autoconf" ,autoconf)
-       ("automake" ,automake)
-       ("libtool" ,libtool)
-       ("python" ,python-minimal-wrapper)))     ;for tests
+     (list python-minimal-wrapper))     ;for tests
     (synopsis "Decoder of the JBIG2 image compression format")
     (description
-      "JBIG2 is designed for lossy or lossless encoding of @code{bilevel} (1-bit
+     "JBIG2 is designed for lossy or lossless encoding of @code{bilevel} (1-bit
 monochrome) images at moderately high resolution, and in particular scanned
 paper documents.  In this domain it is very efficient, offering compression
 ratios on the order of 100:1.