summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-05-07 14:31:44 -0400
committerLeo Famulari <leo@famulari.name>2017-06-19 13:07:20 -0400
commit731b0c727c017df20cead6f63b91d9b3f44febab (patch)
treea82a10cb249f81698cc3b296f4ee942ad4e5a52b /gnu
parent7e60206dff66339b540fb3a0e1e6d2b4eec4994f (diff)
downloadguix-731b0c727c017df20cead6f63b91d9b3f44febab.tar.gz
gnu: Add python-mock-2.
* gnu/packages/python.scm (python-mock-2): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c07bbae3e9..87c4d84a87 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -922,6 +922,24 @@ have been used.")
 (define-public python2-mock
   (package-with-python2 python-mock))
 
+;;; Some packages (notably, certbot and python-acme) rely on this newer version
+;;; of python-mock. However, a large number of packages fail to build with
+;;; mock@2, so we add a new variable for now. Also, there may be a dependency
+;;; cycle between mock and six, so we avoid creating python2-mock@2 for now.
+(define-public python-mock-2
+  (package
+    (inherit python-mock)
+    (version "2.0.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "mock" version))
+        (sha256
+         (base32
+          "1flbpksir5sqrvq2z0dp8sl4bzbadg21sj4d42w3klpdfvgvcn5i"))))
+    (propagated-inputs
+     `(("python-pbr" ,python-pbr-minimal)
+       ,@(package-propagated-inputs python-mock)))))
 
 (define-public python-setuptools
   (package