summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-01-09 14:59:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-01-16 12:44:36 +0100
commit745b208767825f7b5539deb3830053e3f4f2a504 (patch)
treeff6095d60c95b54976e85f0f788a51068fbbb2c2 /gnu
parent1c01f7e5c6b97c2e58e773c5b55d0e072739858a (diff)
downloadguix-745b208767825f7b5539deb3830053e3f4f2a504.tar.gz
gnu: python-pint: Update to 0.23.
* gnu/packages/python-xyz.scm (python-pint): Update to 0.23.
[arguments]: Disable "test_load_definitions_stage_2" test.
[native-inputs]: Remove python-dask, python-distributed,
python-importlib-metadata, python-setuptools-scm, python-sparse,
python-uncertainties, and python-xarray; add python-pytest-benchmark.
[propagated-inputs]: Add python-uncertainties.

Change-Id: I98baae3369e5ffeea96355d9509296771c33dc50
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 16 insertions, 17 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1964b8eb9f..7d70b80e0e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1406,30 +1406,29 @@ Markdown.  All extensions are found under the module namespace of pymdownx.")
 (define-public python-pint
   (package
     (name "python-pint")
-    (version "0.22")
+    (version "0.23")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "Pint" version))
               (sha256
                (base32
-                "0cs4lsvngrkfzpnrmxcwz728m47y0xbw1knksz51cc6gpdm9y4rd"))))
+                "1d69dqs0j907x4hgz2k8f3zjzhgs9zvlw2k0gi955g3dc28rnl71"))))
     (build-system pyproject-build-system)
     (arguments
-     ;; This single test tries to write to $HOME/.cache/pint.
-     (list #:test-flags #~'("-k" "not test_auto")))
-    (native-inputs
-     (list python-dask
-           python-distributed
-           python-importlib-metadata
-           python-pytest                ;for pytest-subtests
-           python-pytest-cov
-           python-pytest-mpl
-           python-pytest-subtests
-           python-setuptools-scm
-           python-sparse
-           python-uncertainties
-           python-xarray))
-    (propagated-inputs (list python-typing-extensions))
+     (list
+      #:test-flags
+      '(list "-k" (string-append
+                   ;; This test tries to write to $HOME/.cache/pint.
+                   "not test_auto"
+                   ;; Fails with "Group USCSLengthInternational already
+                   ;; present in registry"
+                   " and not test_load_definitions_stage_2"))))
+    (native-inputs
+     (list python-pytest python-pytest-benchmark python-pytest-cov
+           python-pytest-mpl python-pytest-subtests))
+    (propagated-inputs
+     (list python-typing-extensions
+           python-uncertainties))
     (home-page "https://github.com/hgrecco/pint")
     (synopsis "Physical quantities module")
     (description