summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-08-06 20:53:12 +0200
committerAndreas Enge <andreas@enge.fr>2013-08-06 20:53:12 +0200
commit755693a42dd01e2d262844aa2455361878e4a6d2 (patch)
tree261dbc1d67fc59e53c40eb427d5ae3d9bbab660b /gnu
parent9c2ecede41b594403b2b831cc68d41cfa4dc402c (diff)
downloadguix-755693a42dd01e2d262844aa2455361878e4a6d2.tar.gz
gnu: xorg: Install fonts into package output instead of into font-util.
* gnu/packages/xorg.scm (font-adobe100dpi, font-adobe75dpi, font-misc-misc,
    font-schumacher-misc): Add configure flag to modify FONTROOTDIR.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/xorg.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index cde6475a09..c1b3ee4c35 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -384,6 +384,11 @@ tracking.")
         ("font-util", font-util)
         ("mkfontdir" ,mkfontdir)
         ("pkg-config" ,pkg-config)))
+    (arguments
+      `(#:configure-flags (list
+        ;; install fonts into subdirectory of package output instead of
+        ;; font-util-?.?.?/share/fonts/X11
+        (string-append "--with-fontrootdir=" %output "/share/fonts/X11"))))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -410,6 +415,9 @@ tracking.")
         ("font-util", font-util)
         ("mkfontdir" ,mkfontdir)
         ("pkg-config" ,pkg-config)))
+    (arguments
+      `(#:configure-flags (list
+        (string-append "--with-fontrootdir=" %output "/share/fonts/X11"))))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -1004,6 +1012,9 @@ tracking.")
         ("font-util" ,font-util)
         ("bdftopcf" ,bdftopcf)
         ("pkg-config" ,pkg-config)))
+    (arguments
+      `(#:configure-flags (list
+        (string-append "--with-fontrootdir=" %output "/share/fonts/X11"))))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")
@@ -1055,6 +1066,9 @@ tracking.")
         ("font-util" ,font-util)
         ("bdftopcf" ,bdftopcf)
         ("pkg-config" ,pkg-config)))
+    (arguments
+      `(#:configure-flags (list
+        (string-append "--with-fontrootdir=" %output "/share/fonts/X11"))))
     (home-page "http://www.x.org/wiki/")
     (synopsis "xorg implementation of the X Window System")
     (description "X.org provides an implementation of the X Window System")