summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:43:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:59 +0200
commit75822fbbfd503b4bd7a098acdb0539ffa29e468b (patch)
tree65ff3c795095340b6b282d64b74fced63dcd99fd /gnu
parent8b53b69bc7163f543435abbd802d883a9bfcfa72 (diff)
downloadguix-75822fbbfd503b4bd7a098acdb0539ffa29e468b.tar.gz
gnu: Add texlive-dvipos.
* gnu/packages/tex.scm (texlive-dvipos): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4ebdca06f7..85fa9971fb 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1868,6 +1868,27 @@ on-the-fly, as needed in @code{preview-latex}, WeBWorK and others.  It does
 not read the postamble, so it can be started before TeX finishes.")
     (license license:lgpl3)))
 
+(define-public texlive-dvipos
+  (package
+    (name "texlive-dvipos")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/man/man1/dvipos.1"
+                   "doc/man/man1/dvipos.man1.pdf")
+             (base32
+              "0dmaas4m9y4px53vlg0jr73xviki338fm2n176l8ldwqj0vvq1b8")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://www.tug.org/texlive/")
+    (synopsis "Support DVI @samp{pos:} specials used by ConTeXt DVI output")
+    (description
+     "@command{dvipos} parses a DVI file looking for @samp{pos:} specials.
+It then outputs the information from those specials along with information
+that only a DVI postprocessor could determine, such as the current @samp{x}
+and @samp{y} location.")
+    (license license:gpl2+)))
+
 (define-public texlive-dvipsconfig
   (package
     (name "texlive-dvipsconfig")