summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
commit7595a07da5583bb33e7fb1290620d045929110c4 (patch)
tree2cd8d6fe4089036250647b3e10ef264211944b54 /gnu
parentc212bdf64f323ebc4148b55983e8e398a3c6f171 (diff)
downloadguix-7595a07da5583bb33e7fb1290620d045929110c4.tar.gz
gnu: whois: Use G-expressions.
* gnu/packages/networking.scm (whois)[arguments]:
Rewrite as G-expressions.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/networking.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 752d706797..93eb8cae85 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1722,18 +1722,19 @@ and up to 1 Mbit/s downstream.")
         (base32 "1mqgc8saz4l0hr4p8r9cgndwx3r9aal7ak9irgrrkxyjd65xpa9n"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; no test suite
-       #:make-flags
-       (list (string-append "CC=" ,(cc-for-target))
-             (string-append "PKG_CONFIG=" ,(pkg-config-for-target))
-             (string-append "prefix=" (assoc-ref %outputs "out"))
-             "BASHCOMPDIR=$(prefix)/share/bash-completion/completions")
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure)            ; no configure script
-         (add-before 'build 'setenv
-           (lambda _
-             (setenv "HAVE_ICONV" "1"))))))
+     (list
+      #:tests? #f                       ; no test suite
+      #:make-flags
+      #~(list (string-append "CC=" #$(cc-for-target))
+              (string-append "PKG_CONFIG=" #$(pkg-config-for-target))
+              (string-append "prefix=" #$output)
+              "BASHCOMPDIR=$(prefix)/share/bash-completion/completions")
+      #:phases
+      #~(modify-phases %standard-phases
+          (delete 'configure)           ; no configure script
+          (add-before 'build 'setenv
+            (lambda _
+              (setenv "HAVE_ICONV" "1"))))))
     (inputs
      (list libidn2))
     (native-inputs