summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-08-19 09:42:22 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-08-19 09:44:12 +0300
commit75a43e53e1c2abb2cfeceb43708ad8e4e4c8f6ab (patch)
treea31f25434b40edbf0b4a29be9715cfc1fdd8614c /gnu
parentb180d6d2842252a275845aad96b8c4b5a6b33156 (diff)
downloadguix-75a43e53e1c2abb2cfeceb43708ad8e4e4c8f6ab.tar.gz
gnu: emacs-git-auto-commit-mode: Update to 4.6.0-1.23abaff.
* gnu/packages/emacs-xyz.scm
(emacs-git-auto-commit-mode)[version]: Update to 4.6.0-1.23abaff.
[native-inputs]: Add emacs-buttercup and git.
[arguments]: Run tests suite.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm42
1 files changed, 25 insertions, 17 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3c12a2f8e8..f8640fcc28 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16504,27 +16504,35 @@ scroll up to read the function name and then scroll down to original position.")
       (license license:gpl3+))))
 
 (define-public emacs-git-auto-commit-mode
-  (package
-    (name "emacs-git-auto-commit-mode")
-    (version "4.5.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/ryuslash/git-auto-commit-mode")
-             (commit version)))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "1w3v9pmlmdxl4pglsb6j0igp13lbzg5bhbr1rv2vll93m6zxmyma"))))
-    (build-system emacs-build-system)
-    (home-page "https://github.com/ryuslash/git-auto-commit-mode")
-    (synopsis "Emacs Minor mode to automatically commit and push")
-    (description "@code{git-auto-commit-mode} is an Emacs minor mode that
+  (let ((commit "23abaff792c0459e51e596d3fecd5513617e8cb1")
+        (revision "1"))
+    (package
+      (name "emacs-git-auto-commit-mode")
+      (version (git-version "4.6.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/ryuslash/git-auto-commit-mode")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0hqj34q8z4jg86zz2lwfvj6xk07b4g1222h9y1zqs83qgivwpk1l"))))
+      (build-system emacs-build-system)
+      (native-inputs
+       `(("emacs-buttercup" ,emacs-buttercup)
+         ("git" ,git)))
+      (arguments
+       `(#:tests? #t
+         #:test-command '("buttercup" "-L" ".")))
+      (home-page "https://github.com/ryuslash/git-auto-commit-mode")
+      (synopsis "Emacs Minor mode to automatically commit and push")
+      (description "@code{git-auto-commit-mode} is an Emacs minor mode that
 tries to commit changes to a file after every save.
 
 When @code{gac-automatically-push-p} is non-nil, it also tries to push to
 the current upstream.")
-    (license license:gpl3+)))
+      (license license:gpl3+))))
 
 (define-public emacs-scroll-on-drag
   (let ((commit "888abd04c34753b1fc4b2fe541bc004ebec5c996")