summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-08-29 09:20:18 +0300
committerAndrew Tropin <andrew@trop.in>2022-08-29 09:55:44 +0300
commit75d73172904f3b6a0fc077297b5a00750af3b16c (patch)
tree2e09584c308fba278e57ac32b604669e3a1ab085 /gnu
parent0ea62e84a787fe94cfeadf67ef27ea995a382b84 (diff)
downloadguix-75d73172904f3b6a0fc077297b5a00750af3b16c.tar.gz
gnu: fennel: Update to 1.2.0.
* gnu/packages/lua.scm (fennel): Update to 1.2.0.
[arguments]: Migrate to gexps.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/lua.scm75
1 files changed, 35 insertions, 40 deletions
diff --git a/gnu/packages/lua.scm b/gnu/packages/lua.scm
index afebc6bc1f..c3bb1e8f5b 100644
--- a/gnu/packages/lua.scm
+++ b/gnu/packages/lua.scm
@@ -1179,48 +1179,43 @@ enabled.")
    (license license:boost1.0)))
 
 (define-public fennel
-  ;; The 1.0.0 release had a bug where fennel installed under 5.4 no matter
-  ;; what lua was used to compile it. There has since been an update that
-  ;; corrects this issue, so we can rely on the version of the lua input to
-  ;; determine where the fennel.lua file got installed to.
-  (let ((commit "03c1c95f2a79e45a9baf607f96a74c693b8b70f4")
-        (revision "0"))
-    (package
-      (name "fennel")
-      (version (git-version "1.0.0" revision commit))
-      (source (origin
-                (method git-fetch)
-                (uri (git-reference
-                      (url "https://git.sr.ht/~technomancy/fennel")
-                      (commit commit)))
-                (file-name (git-file-name name version))
-                (sha256
-                 (base32
-                  "1znp38h5q819gvcyl248zwvjsljfxdxdk8n82fnj6lyibiiqzgvx"))))
-      (build-system gnu-build-system)
-      (arguments
-       '(#:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
-         #:tests? #t      ; even on cross-build
-         #:test-target "test"
-         #:phases
-         (modify-phases %standard-phases
-          (delete 'configure)
-          (add-after 'build 'patch-fennel
-           (lambda* (#:key inputs #:allow-other-keys)
-            (substitute* "fennel"
-             (("/usr/bin/env .*lua")
-              (search-input-file inputs "/bin/lua")))))
-          (delete 'check)
-          (add-after 'install 'check
-           (assoc-ref %standard-phases 'check)))))
-      (inputs (list lua))
-      (home-page "https://fennel-lang.org/")
-      (synopsis "Lisp that compiles to Lua")
-      (description
-       "Fennel is a programming language that brings together the speed,
+  (package
+    (name "fennel")
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.sr.ht/~technomancy/fennel")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0klqxhgc9s6rm2xbn2fyzw9nzdas65g84js7s69by0gv2jzalyad"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:make-flags #~(list (string-append "PREFIX="
+                                               (assoc-ref %outputs "out")))
+           #:tests? #t ;even on cross-build
+           #:test-target "test"
+           #:phases #~(modify-phases %standard-phases
+                        (delete 'configure)
+                        (add-after 'build 'patch-fennel
+                          (lambda* (#:key inputs #:allow-other-keys)
+                            (substitute* "fennel"
+                              (("/usr/bin/env .*lua")
+                               (search-input-file inputs "/bin/lua")))))
+                        (delete 'check)
+                        (add-after 'install 'check
+                          (assoc-ref %standard-phases
+                                     'check)))))
+    (inputs (list lua))
+    (home-page "https://fennel-lang.org/")
+    (synopsis "Lisp that compiles to Lua")
+    (description
+     "Fennel is a programming language that brings together the speed,
 simplicity, and reach of Lua with the flexibility of a Lisp syntax and macro
 system.")
-      (license license:expat))))
+    (license license:expat)))
 
 (define-public fnlfmt
   (package