summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-17 21:16:46 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-19 20:33:27 +0200
commit76272cc6619a8d042da16dfb13273ee000518d3d (patch)
tree667d2e7b77b4e8390f7c2704b489f2b1fdad0b5c /gnu
parent8b2d626fb3cc1b81815ddce1f2a24b5d5e7b0e47 (diff)
downloadguix-76272cc6619a8d042da16dfb13273ee000518d3d.tar.gz
gnu: Add texlive-biblatex-opcit-booktitle.
* gnu/packages/tex.scm (texlive-biblatex-opcit-booktitle): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 71f8476e14..5051706bce 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -4237,6 +4237,27 @@ Journal of Medicine (NEJM).")
 University of Nottingham.")
     (license license:lppl1.3+)))
 
+(define-public texlive-biblatex-opcit-booktitle
+  (package
+    (name "texlive-biblatex-opcit-booktitle")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/latex/biblatex-opcit-booktitle/"
+                   "tex/latex/biblatex-opcit-booktitle/")
+             (base32
+              "078fzk4i7sknaxkgn2lr54bcslqbjjsr1nb0z7y46v7kpg2lpcrf")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/biblatex-opcit-booktitle")
+    (synopsis "Use @samp{op.@: cit.}@: for the booktitle of a subentry")
+    (description
+     "The default citation styles use the @samp{op.@: cit.}@: form in order to
+have a shorter reference when a title has already been cited.  However, when
+you cite two entries which share the same booktitle but not the same title,
+the @samp{op.@: cit.}@: mechanism does not work.  This package fixes this.")
+    (license license:lppl1.3+)))
+
 (define-public texlive-bibleref
   (package
     (name "texlive-bibleref")