summary refs log tree commit diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 14:50:21 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:51 +0200
commit76b2288826ebde2aa6fc87975f16a32e6b3e026d (patch)
treec739ddce149f1b30419b4a045e4cddb4b7c9a3a0 /gnu
parent675192ed0d8646fd6576984aac6e33575bccf589 (diff)
downloadguix-76b2288826ebde2aa6fc87975f16a32e6b3e026d.tar.gz
gnu: Add texlive-markdown.
* gnu/packages/tex.scm (texlive-markdown): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index bc3f909ad2..c312f0eb35 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5661,6 +5661,34 @@ is much more flexible, since it can be used as direct replacement for
 provided by @code{tex.mp}.")
     (license license:public-domain)))
 
+(define-public texlive-markdown
+  (package
+    (name "texlive-markdown")
+    (version (number->string %texlive-revision))
+    (source (texlive-origin
+             name version
+             (list "doc/context/third/markdown/examples/"
+                   "doc/generic/markdown/"
+                   "doc/latex/markdown/examples/"
+                   "scripts/markdown/"
+                   "source/generic/markdown/"
+                   "tex/context/third/markdown/"
+                   "tex/generic/markdown/"
+                   "tex/latex/markdown/"
+                   "tex/luatex/markdown/")
+             (base32
+              "0nmw1c4ynn0vzdkgpz2dnqimbxbyl6pc0khl2gbi8bd4g9dkai55")))
+    (outputs '("out" "doc"))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/markdown")
+    (synopsis "Converting and rendering Markdown documents inside TeX")
+    (description
+     "The package provides facilities for the conversion of Markdown markup to
+plain TeX.  These are provided both in form of a Lua module and in form of
+plain TeX, LaTeX, and ConTeXt macro packages that enable the direct inclusion
+of Markdown documents inside TeX documents.")
+    (license license:lppl1.3c)))
+
 (define-public texlive-mcf2graph
   (package
     (name "texlive-mcf2graph")